01-HTTPOXY vulnerability - Apache Web Server Hardening

امنیت در لینوکس

01-Linux Apache Web Server Hardening

To ensure that the server can not be attacked trough the HTTPOXY vulnerability, we will disable the HTTP_PROXY header in apache globally by adding the configuration file /etc/apache2/conf-available/httpoxy.conf.

1.1 Install packages

Paste the following content to the file:

root@deb:~# cat /etc/apache2/conf-available/httpoxy.conf
<IfModule mod_headers.c>
    RequestHeader unset Proxy early
</IfModule>
1.2 And enable the module by running:
root@deb:~# a2enconf httpoxy
root@deb:~# service apache2 restart
مطالب و دوره های آموزشی مرتبط
مطالب و دوره های آموزشی مرتبط
مطالب و دوره های آموزشی مرتبط

 

برچسب ها: Apache2, Linux Hardening, Apache Virtual Host, Web Server Hardening, HTTPOXY vulnerability

نوشتن دیدگاه


تصویر امنیتی
تصویر امنیتی جدید

  • همه
  • FreeBSD
  • GUI
  • Linux
  • LPIC1
  • LVM
  • RHEL
  • Sysadmin
موارد دیگر کلید SHIFT را برای نمایش همه نگه دارید نمایش همه